Skip to main content
Version: v4

Foursquare

Documentation#

https://developer.foursquare.com/docs/places-api/authentication/#web-applications

Configuration#

https://developer.foursquare.com/

warning

Foursquare requires an additional apiVersion parameter in YYYYMMDD format, which essentially states "I'm prepared for API changes up to this date".

Options#

The Foursquare Provider comes with a set of default options:

You can override any of the options to suit your own use case.

Example#

import FourSquareProvider from `next-auth/providers/foursquare`...providers: [  FourSquareProvider({    clientId: process.env.FOURSQUARE_CLIENT_ID,    clientSecret: process.env.FOURSQUARE_CLIENT_SECRET,    apiVersion: 'YYYYMMDD'  })]...